Pasek boczny
Konto
Konto
Szukaj
Szukaj
Ustawienia
Ustawienia
Szukaj

Szukaj w:



Zaawansowane wyszukiwanie
Ustawienia
Przełącz na wersję mobilną
Motyw
Język



Tonery i tusze do drukarek Notariusz Katowice Adwokat Katowice





Windows 8.1: Hamachi a Windows 8.1 (zaktualizowany)
  • 0 głosów - średnia: 0
  • 1
  • 2
  • 3
  • 4
  • 5
Subskrybuj ten wątek
madhat
Użytkownik
Offline

Reputacja: 0

 0     0    
1   26-10-2013, 21:01   
Edytuj ten post      Cytuj     
Witam,
mam problem z hamachi po aktualizacji z Windows 8 x64 na Windows 8.1. Mianowicie na pierwotnej wersji win8 wszytko działało bez najmniejszych problemów. Natomiast po aktualizacji systemu Hamachi ładuje się pięknie. Wszystkie kropki mam na zielono. Więdzę sieci i pozostałe komputery, tylko nie mogę się z nimi łączyć np. przez vnc, ale nawet ich pingować. Oni z resztą mnie też nie mogą puścić pinga.
Wszedłem w ustawienia zapory i sprawdzilem wyjątki. Hamachi ma swój i jest pięknie, ale łączność dalej leży. Dla pewności stworzyłem ręcznie własne wyjątki dla Hamachi i zrestartowałem komputer.
Ku mojemu zdziwieniu wszystko tym razem zadziałało. Pingi są, połączenia aktywne i działają. Poszedłem sprać.
Rano odpalam maszynę i analogiczna sytuacja. Hamachi działa, a pingi i połączeń brak pomimo zielonych kropek. Wchodzę ponownie do zapory i wszystko jest tak jak ustawilem dzień wcześniej. Jednak po odświeżeniu okna z ustawieniami okazuje się, że pojawił się drugi analogiczny wpis o wyjątku w zaporze dla Hamachi. Tak samo w przychodzących, jak i wychodzących. Początkowo to zignorowałem, ale później nie mogąc znaleźć rozwiązania usunąłem po jednym z niepotrzebnych wpisów i ponownie uruchomiłem komputer. No i Hamachi działa w najepsze >13
Zamknąłem komputer i jak się pewnie domyślacie po ponownym uruchomieniu Hamachi już nie łączyło, ani nie pingowało niczego. Analogicznie jak poprzednio. Obserwując ustawienia zapory zauważyłem po kilkukrotnych restartach komputera, że ilość wpisów o wyjątkach dla połączeń przychodzących i wychodzących w zaporze, z każdym uruchomieniem powiela się o nowy identyczny wpis. Tak więc koniec końców miałem po wielu uruchomieniach kilkanaście wpisów identycznym dotyczących wyjątków Hamachi.
Po usunięciu ich i restarcie Hamachi każdorazowo wraca do porządku, na tą jedną sesję. Po ponownym restarcie ilość wpisów znowu wzrasta o jeden identyczny i Hamachi nie działa.
Hamachi jest mi niezbędne, więc za wszelkie sugestie będę wdzięczny.
Problem mnie denerwuje, ale ponieważ nie mogę póki co rozwiązać jego przyczyny, to spróbowałem poradzić sobie z nim w inny "doraźny" sposób. Jak nie kijem go to pałką.
Wykorzystałem w tym celu instalator hamachi, z pliku HAMACHI.MSI. Plik umieściłem, żeby nie przeszkadzał w folderze programu Hamachi w Program Files.
Następnie utworzyłem mały plik batch, który nazwałem hamachi_fix.bat. Jego treść jest następująca:
@echo off
c:
cd c:\Program Files (x86)\LogMeIn Hamachi
start /min msiexec /quiet /f hamachi.sys
start hamachi-2-ui.exe

Umieściłem tak przygotowany plik w folderze Autostartu i w ten sposób każdorazowo po włączeniu komputera mój plik wyłącza hamachi i "naprawia" instalację, a następnie uruchamia całość z naniesionymi już poprawkami.
Jak widać wykorzystałem funkcję naprawy hamachi przez instalator wywoływaną z komendy. Instaler naprawia hamachi, co wydłuża jego ładowanie o jakieś 15-20 sekund i dopiero uruchamia intefejs i działającą usługę.
Działa wyśmienicie. Zapory powłączane na maxa i nic nie laguje, a pingi chodzą bez najmniejszego zacięcia.
Chociaż póki co dalej będę szukał przyczyny problemów, ponieważ powyższy sposób traktuję jako chwilowe jego obejście.




Zaloguj się lub zarejestruj, aby odpowiedzieć w temacie.
Dołącz do naszej społeczności!


Zarejestruj się
Posiadasz konto? Kliknij poniżej.


Zaloguj się


Użytkownicy przeglądający ten wątek: 1 gości

Centrum napraw komputerów Warszawa

Portal  Kontakt  Pomoc  Facebook 
© CentrumWindows
Polskie tłumaczenie © 2007-2016 Polski Support MyBB
Silnik forum MyBB, © 2002-2017 MyBB Group
Biznes-Host